Functions

  check_version (required_major, required_minor, required_micro)
  error_quark ()

Details

Cattle.check_version(required_major, required_minor, required_micro)[source]
Parameters:
  • required_major (int) – required major version
  • required_minor (int) – required minor version
  • required_micro (int) – required micro version
Returns:

True if the runtime library is compatible, False otherwise

Return type:

bool

Check the Cattle library used at runtime is compatible with the required version described by required_major, required_minor and required_micro.

Cattle.error_quark()[source]
Return type:int